Table of Contents

This article will provide information about the base packages available with your Cloudways server with the default Debian 10 distribution. We will also provide information on how it can be checked and verified. Debian 10 is available on all the servers launched after January 12th, 2022.

We offer one-click deployment of the server with the freedom to choose the best infrastructure provider available. All the Cloudways servers also come with various default packages and extensions/modules to create an equilibrium between your web applications’ performance and stability.

Nginx

Cloudways Platform comes with a web server called Nginx as a part of our default web stack. All of our cloud servers are equipped with robust Nginx to serve static content requests. It helps to serve more audiences rapidly while lowering down the load on your server as it needs minimal resources. The currently available version of Nginx is 1.21.x, and the available ports are 80 and 443.

How to Verify Nginx Version

  1. To verify the Nginx version, connect to your server via SSH.

  2. Once you are connected, execute the following command to view the details.

dpkg -l | grep nginx

Varnish

Cloudways Platform offers built-in Varnish Cache as a part of our optimization stack. It is an open-source HTTP accelerator designed for dynamic websites to cache and deliver static and dynamic content requests. The currently available version of Varnish is 6.0.x. It works excellent with Nginx and Apache to provide a superior experience to your site visitors.

How to Verify Varnish Version

  1. To verify the Varnish version, connect to your server via SSH.

  2. Once you are connected, execute the following command to view the details.

dpkg -l | grep varnish

Apache

Apache is a renowned HTTP web server and is developed and maintained by Apache Foundation. Cloudways Platform also includes a blazing-fast Apache web server as a part of our lightning-fast and optimized web stack. Apache is well known for its reliability, compatibility, and impressive range of features. The installed version is Apache 2.4.x for Debian 10 servers.

How to Verify Apache Version

  1. To verify the Apache version, connect to your server via SSH.

  2. Once you are connected, execute the following command to view the details.

dpkg -l | grep apache

Apache Modules

Most of the default modules are available on the servers. Modules that are not enabled by default can be requested by contacting our Support Team via Live Chat or opening a support ticket to check the possibility of enabling it.

Below is the list of most commonly used Apache modules:

core_module (static)
so_module (static)
watchdog_module (static)
http_module (static)
log_config_module (static)
logio_module (static)
version_module (static)
unixd_module (static)
access_compat_module (shared)
actions_module (shared)
alias_module (shared)
auth_basic_module (shared)
authn_core_module (shared)
authn_file_module (shared)
authz_core_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
expires_module (shared)
fcgid_module (shared)
filter_module (shared)
headers_module (shared)
mime_module (shared)
mpm_event_module (shared)
negotiation_module (shared)
proxy_module (shared)
proxy_fcgi_module (shared)
remoteip_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
rpaf_module (shared)
setenvif_module (shared)
socache_shmcb_module (shared)
ssl_module (shared)
status_module (shared)

Database

Our stack includes MariaDB 10.4 as a default database of your web application. You can always upgrade to the latest version, e.g., MariaDB 10.6, as per your requirements. You can not downgrade MariaDB packages.

Question

Why Cloudways offers MariaDB and not MySQL?

MariaDB is an advanced version and a compatible drop-in replacement for the equivalent MySQL version. Read more about why Cloudways offers MariaDB?.

You can also verify and see all the available database versions using the Cloudways Platform. Click here to read more information about it.

Memcached

Memcached is a caching system used to speed up dynamic web applications by storing data in the server’s memory for a limited time to ease the load on the database. The installed version of Memcached is 1.5.x.

How to Verify Memcached Version

  1. To verify the Memcached version, connect to your server via SSH.

  2. Once you are connected, execute the following command to view the details.

dpkg -l | grep memcached

PHP

Your new server is configured to use PHP 7.4 by default. You can always upgrade to the latest version, e.g., PHP 8.1, as per your requirements. Downgrading the PHP version has some limitations, so you can view which PHP versions you can upgrade or downgrade to currently.


Important Announcement for PHP Older Versions

Available versions of PHP include PHP 5.6, 7.0, 7.1, 7.2, 7.3, 7.4, 8.0, and 8.1 but 5.6, 7.0, 7.1, 7.2, and 7.3 versions are deprecated as of August 15th, 2022. As a result, new and existing servers with default PHP 7.4 or newer versions will not have an option to downgrade to older and deprecated versions; however, existing servers with deprecated versions will continue to work for the time being.

The deprecated versions will reach the end of life on February 28th, 2023; therefore, you are requested to upgrade to the latest version. Please refer to Cloudways deprecation process and policy for more details.


The latest version is PHP 8.1, which requires Debian 9 or Debian 10. It is not compatible with Debian 7 and Debian 8. You can also check your application compatibility with different available PHP versions.


How to Verify PHP Version

  1. To verify the PHP version, connect to your server via SSH.

  2. Once you are connected, execute the following command to view the details.

php -v

PHP Extensions/Modules

A large number of PHP extensions/modules are installed according to the selected PHP version.

Tip

PHP extensions/modules that are not enabled by default can be requested by contacting us via Live Chat or support ticket to check the possibility of enabling it.

PHP 5.6.x Extensions

The following extensions are available for PHP 5.6.x version. Also, this version supports ZendGuard and xDebug which can be enabled from the server settings.

[PHP Modules]
apc
apcu (version 4.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date
dom (API version 20031129)
ereg
exif (version 1.4 | supported exif version 0220)
fileinfo (version 1.0.x)
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
hash
iconv (version 2.24)
igbinary (version 2.0.x)
imagick (version 3.4.x)
imap (version 2007f)
intl (version 1.1.x)
ionCube Loader (version 6.0.x)
json (version 1.2.x)
libxml (version 2.9.x)
mbstring
mcrypt (version 2.5.x)
memcache (version 3.0.9-dev)
memcached (version 2.2.x)
mhash
mongo (version 1.6.x)
msgpack (extension version 0.5.x | header version 0.5.x)
mysql
mysqli
mysqlnd (version 5.0.11-dev)
openssl (library version 1.1.1i | header version 1.1.1i)
pcntl
pcre (library version 8.43)
PDO
pdo_mysql
pdo_sqlite
Phar (EXT version 2.0.x | API version 1.1.x)
posix
readline
Reflection
session
shmop
SimpleXML
sockets
SPL
sqlite3 (module version 0.7-dev | library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (xmlrpc-epi v. 0.54 | php extension version 0.51)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 7.0.6-dev)
zip (version 1.12.x | libzip version 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 7.0.6-dev)
the ionCube PHP Loader + Intrusion Protection from ioncube24.com (version 6.0.x)

PHP 7.0.x Extensions

The following extensions are available for PHP 7.0.x version. Also, this version supports xDebug which can be enabled from the server settings. ZendGuard is not supported in this PHP version.

[PHP Modules]
apc
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date (timelib version 2016.02)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.5.x)
exif (version 0220)
fileinfo (version 1.0.x)
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
gmp (version 6.1.x)
hash
iconv (library version 2.24)
igbinary (version 3.1.x)
imagick (version 3.4.x)
imap (c-Client version 2007f)
interbase
intl (version 1.1.x)
ionCube Loader (version 6.0.x)
json (version 1.4.x)
libxml (compiled version 2.9.x | loaded version 20909)
mbstring
mcrypt (version 2.5.x)
memcached (version 3.1.x)
mongodb (extension version 1.9.x)
msgpack (extension version 2.1.x | header version 3.2.x)
mysqli
mysqlnd (version 5.0.12-dev)
odbc
openssl (library version 1.1.1i | header version 1.1.1i)
pcntl
pcre (library version 8.43)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql (version 9.6.x)
Phar (EXT version 2.0.x | API version 1.1.x)
posix
readline
recode
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
sqlite3 (library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tidy
tokenizer
wddx
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (xmlrpc-epi v. 0.54)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 7.0.x)
zip (version 1.13.x | libzip 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 7.0.x)
the ionCube PHP Loader + Intrusion Protection from ioncube24.com (version 6.0.x)

PHP 7.1.x Extensions

The following extensions are available for PHP 7.1.x version. Also, this version supports xDebug which can be enabled from the server settings. ZendGuard is not supported in this PHP version.

[PHP Modules]
apc
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date (timelib version 2016.05)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.5.x)
exif (version 0220)
fileinfo (version 1.0.x)
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
gmp (version 6.1.x)
hash
iconv (library version 2.24)
igbinary (version 3.2.x)
imagick (version 3.4.x)
imap (c-Client version 2007f)
interbase
intl (version 1.1.x)
ionCube Loader (version 10.0.x)
json (version 1.5.x)
libxml (compiled version 2.9.x | loaded version 20909)
mbstring
mcrypt (version 2.5.x)
memcached (version 3.1.x)
mongodb (extension version 1.9.x)
msgpack (extension version 2.1.x | header version 3.2.x)
mysqli
mysqlnd (version 5.0.12-dev)
odbc
openssl (library version 1.1.1i | header version 1.1.1i)
pcntl
pcre (library version 8.43)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql (version 9.6.x)
Phar (EXT version 2.0.x | API version 1.1.x)
posix
readline
recode
Reflection
session
shmop
SimpleXML
soap
sockets
SPL
sqlite3 (library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tidy (libTidy version 5.6.x)
tokenizer
wddx
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (xmlrpc-epi v. 0.54)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 7.1.x)
zip (version 1.13.x | libzip 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 7.1.x)
the ionCube PHP Loader + Intrusion Protection from ioncube24.com (version 10.0.x)

PHP 7.2.x Extensions

The following extensions are available for PHP 7.2.x version. Also, this version supports xDebug which can be enabled from the server settings. ZendGuard is not supported in this PHP version.

[PHP Modules]
apc
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date (timelib version 2017.09)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.5.x)
exif (supported version 0220)
fileinfo (version 1.0.x)
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
gmp (version 6.1.x)
hash
iconv (library version 2.24)
igbinary (version 3.2.x)
imagick (version 3.4.x)
imap (c-Client version 2007f)
interbase
intl (version 1.1.x)
ionCube Loader (version 10.2.x)
json (version 1.6.x)
libxml (compiled version 2.9.x | loaded version 20909)
mbstring
memcached (version 3.1.x)
mongodb (extension version 1.9.x)
msgpack (extension version 2.1.x | header version 3.2.x)
mysqli
mysqlnd (version 5.0.12-dev)
odbc
openssl (library version 1.1.1i | header version 1.1.1i)
pcntl
pcre (library version 8.43)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql (version 9.6.x)
Phar (EXT version 2.0.x | API version 1.1.x)
posix
readline
recode
Reflection
session
shmop
SimpleXML
soap
sockets
sodium (libsodium headers version 1.0.x | libsodium library version 1.0.x)
SPL
sqlite3 (library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tidy (libTidy version 5.6.x)
tokenizer
wddx
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (xmlrpc-epi v. 0.54)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 7.2.x)
zip (version 1.15.x | libzip headers version 1.7.x | libzip library version 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 7.2.x)
the ionCube PHP Loader + Intrusion Protection from ioncube24.com (version 10.2.x)

PHP 7.3.x Extensions

The following extensions are available for PHP 7.3.x version. Also, this version does not support Zendguard and xDebug.

[PHP Modules]
apc
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date (timelib version 2018.04)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.5.x)
exif (version 0220)
fileinfo
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
gmp (version 6.1.x)
hash
iconv (version 2.24)
igbinary (version 3.2.x)
imagick (version 3.4.x)
imap (c-Client version 2007f)
interbase
intl
ionCube Loader (version 10.3.x)
json (version 1.7.x)
libxml (compiled version 2.9.x | loaded version 20909)
mbstring
memcached (version 3.1.x)
mongodb (extension version 1.9.x)
msgpack (extension version 2.1.x | header version 3.2.x)
mysqli
mysqlnd (version 5.0.12-dev)
odbc
openssl (library version 1.1.1i | header version 1.1.1i)
pcntl
pcre (library version 10.34)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite (library version 3.16.x)
pgsql (version 9.6.x)
Phar (API version 1.1.x)
posix
readline
recode
Reflection
session
shmop
SimpleXML
soap
sockets
sodium (libsodium headers version 1.0.x | libsodium library version 1.0.x)
SPL
sqlite3 (library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tidy (libTidy version 5.6.x)
tokenizer
wddx
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (xmlrpc-epi v. 0.54)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 7.3.x)
zip (version 1.15.x | libzip headers version 1.7.x | libzip library version 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 7.3.x)
the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (version 10.3.x)

PHP 7.4.x Extensions

The following extensions are available for PHP 7.4.x version. Also, this version does not support Zendguard and xDebug.

[PHP Modules]
apc
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date (timelib version 2018.04)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.6.x)
exif (version 0220)
FFI
fileinfo
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
gmp (version 6.1.x)
hash
iconv (library version 2.24)
igbinary (version 3.2.x)
imagick (module version 3.4.x)
imap (c-Client version 2007f)
intl
ionCube Loader (version 10.4.x)
json
libxml (compiled version 2.9.x | loaded version 20909)
mbstring
memcached (version 3.1.x)
mongodb (extension version 1.9.x)
msgpack (extension version 2.1.x | header version 3.2.x)
mysqli
mysqlnd (version 7.4.x)
odbc
openssl (library version 1.1.1i | header version 1.1.1i)
pcntl
pcre (library version 10.34)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql (version 9.6.x)
Phar (API version 1.1.x)
posix
readline
Reflection
session
shmop
SimpleXML
soap
sockets
sodium (header version 1.0.x | library version 1.0.x)
SPL
sqlite3 (library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tidy (libTidy version 5.6.x)
tokenizer
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (xmlrpc-epi v. 0.54)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 7.4.x)
zip (version 1.15.x | header version 1.7.x | library version 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 7.4.x)
the ionCube PHP Loader + ionCube24 (version 10.4.x)

PHP 8.0.x Extensions

The following extensions are available for PHP 8.0.x version. Also, this version supports xDebug which can be enabled from the server settings. ZendGuard and IonCube are currently not supported in this PHP version.

[PHP Modules]
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.52.x)
date (timelib version 2020.02)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.6.x)
exif (version 0220)
FFI
fileinfo
filter
ftp
gd (headers version 2.2.x | library version 2.2.x)
gettext
gmp (version 6.1.x)
hash
iconv (library version 2.24)
igbinary (version 3.2.x)
imagick (module version 3.4.x)
imap (c-Client version 2007f)
intl
json
libxml (compiled version 2.9.x | loaded version 20909)
mbstring
memcached (version 3.1.x)
mongodb (extension version 1.9.x)
msgpack (extension version 2.1.x | header version 3.2.x)
mysqli
mysqlnd (version 8.0.x)
odbc
openssl (library version 1.1.1g | header version 1.1.1i)
pcntl
pcre (library version 10.34)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql (version 9.6.x)
Phar (API version 1.1.x)
posix
readline
Reflection
session
shmop
SimpleXML
soap
sockets
sodium (header version 1.0.x | library version 1.0.x)
SPL
sqlite3 (library version 3.16.x)
standard
sysvmsg
sysvsem
sysvshm
tidy (libTidy version 5.6.x)
tokenizer
xml (libxml2 version 2.9.x)
xmlreader
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (version 8.0.x)
zip (version 1.19.x | libzip version 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)
--
[Zend Modules]
Zend OPcache (version 8.0.x)

PHP 8.1.x Extensions

The following extensions are available for PHP 8.0.x version. Also, this version supports xDebug, which can be enabled from the server settings. ZendGuard and IonCube are currently not supported in this PHP version. In addition, Zend OPcache is disabled.

[PHP Modules]
apcu (version 5.1.x)
bcmath
bz2 (version 1.0.x)
calendar
Core
ctype
curl (version 7.64.x)
date (timelib version 2021.12)
dba (libdb header version Berkeley DB 5.3.x | libdb library version Berkeley DB 5.3.x)
dom (API version 20031129)
enchant (libenchant version 1.6.x)
exif (version 0220)
FFI
fileinfo
filter
ftp
gd (headers version 2.3.x | library version 2.3.x)
gettext
gmp (version 6.1.x)
hash
iconv (library version 2.28)
igbinary (version 3.2.x)
imagick (module version 3.6.x)
imap (c-Client version 2007f)
intl
json
libxml (compiled version 2.9.x | loaded version 20912)
mbstring
memcached (version 3.2.x)
mongodb (extension version 1.13.x)
msgpack (extension version 2.2.0RC1 | header version 3.2.x)
mysqli
mysqlnd (version 8.1.x)
odbc
openssl (library version 1.1.1d | header version 1.1.1n)
pcntl
pcre (library version 10.40)
PDO
pdo_dblib
PDO_Firebird
pdo_mysql
PDO_ODBC
pdo_pgsql
pdo_sqlite
pgsql (version 11.14)
Phar (API version 1.1.x)
posix
readline
redis (version 5.3.x)
Reflection
session
shmop
SimpleXML
soap
sockets
sodium (header version 1.0.x | library version 1.0.x)
SPL
sqlite3 (library version 3.27.x)
standard
sysvmsg
sysvsem
sysvshm
tidy (libTidy version 5.6.x)
tokenizer
xml (libxml2 version 2.9.x)
xmlreader
xmlrpc (extension version 1.0.0RC3 | core library version xmlrpc-epi v. 0.54)
xmlwriter
xsl (libxslt version 1.1.x)
Zend OPcache (disabled)
zip (version 1.19.x | libzip version 1.7.x)
zlib (compiled version 1.2.x | linked version 1.2.x)

[Zend Modules]
Zend OPcache (disabled)

Additional Modules/Extensions

The following modules/extensions are installed beside the standard modules/extensions:

Module name

Version

Git supported

2.20.x

Composer

2.2.x

New Relic Lite

8.x

Cloudways API

Redis

6.2.x

ElasticSearch

7.6. 7.9, and 7.17

That’s it! We hope this article was helpful. If you need any help, then feel free to search your query on Cloudways Support Center or contact us via chat (Need a Hand > Send us a Message). Alternatively, you can also create a support ticket.

Did this answer your question?